Wifi 接駁問題

有個問題想問問

Router 係 D-link DIR-605, notebook係Fujitsu既E8420, 用Intel既5300 wifi-link, router距離notebook都有6-7M, 中間仲有阻隔, 上網時遇到以下情況:
1. Router set N only, notebook會經常斷link, ping router時10次ping內就一定time-out, 幾秒後可以繼續, 但ping10次內有再time-out, 這種情況根本不能正常上網
2. Router set B/G only, notebook當然會用G來connect, 這種情況上網會比較正常, ping router時大部分時間都係1-2ms, 但間中都會出現幾百個ms, 但幾百個ms既情況通常都只係維持半分鐘到一分鐘,之後都變返1-2ms
3. Router set B/G/N, notebook會出現#1種情況, 但如果係notebook個network adaptor裡面個advance setting, force唔用"N" mode, 就會出現#2種情況
4. 如果接駁去屋企附近冇密碼的G router時, 都好正常
5. 另一部本身係G既LG notebook, 就係#2/#3情況下都運作正常
6. 以前未用Fujitsu時, 我買左個DWA-140畀部LG notebook用N來接駁, 都一齊正常
7. 初初買Fujitsu返來時,還未upgrade上WIN7, 用N去connect個router都好正常, 記憶中都係upgrade左上WIN7後至出現這種情況,但用WIN7去detect一下個5300 wifi-link有冇新D既driver, 又話我已經係最新既driver
8. 最初有問題時, 曾經係近距離(1M內) 用N來connect router, 都好正常

唯一未試過就係接駁另一部N router, 到底係咪5300 wifi-link 既driver唔夾router, 還是其他問題, 有冇其他人試過我的問題

Anyone help?

TOP

Good to see you had performed a certain number of inspection. According to #7,  u may also try to use 2 other types of driver as follow.

(a) Fujitsu official drivers for Notebook (Select your OS and Intel Wireless LAN)
http://www.pc-ap.fujitsu.com/support/lb_OS_e8420.html

(b) Intel official drivers for Intel® PRO/Wireless and WiFi Link
Win7 32-bit  http://downloadcenter.intel.com/ ... =18211&lang=eng
Win7 64-bit  http://downloadcenter.intel.com/ ... =18212&lang=eng
** Quote from Intel -
Intel recommends that you obtain and use the software provided via your laptop manufacturer.

TOP