請教cisco高手, 網絡高手幫忙

本帖最後由 office2003 於 2012-5-21 00:13 編輯

請教cisco高手網絡高手幫幫忙, 小弟用cisco1841 + pccw pppoe 7年, 上年年尾轉左hkbn ftth 100m到出事前都用左6個月左右, 一直都無問題的, 但由4月中開始有事, 每15分鐘個wan(fe0/1)就會上唔到網, 個message log大約係話個dns有問題, 只要replug一次fe0/1 條lan 線又可以上返網, 但15分鐘後又上唔網了, 每次都要重覆以上動作, 我試過改interface mtu, speed, full/half duplex, dns timeout, nat timeout都係解決唔到, 之後轉用rv042就咩事都無, 証明hkbn條line無問題, 本以為隻1841死左, 姑且最後去朋友屋企再試, 朋友用pccw ftth 100m, 點知咩事都無, 完全正常無斷線仲好鬼快添, 所以希望請高手ching幫幫小弟

俾個SYSLOG 黎睇下

TOP

cisco1841#show log
Syslog logging: enabled (0 messages dropped, 3 messages rate-limited,
                0 flushes, 0 overruns, xml disabled, filtering disabled)

No Active Message Discriminator.



No Inactive Message Discriminator.


    Console logging: level critical, 0 messages logged, xml disabled,
                     filtering disabled
    Monitor logging: level debugging, 0 messages logged, xml disabled,
                     filtering disabled
    Buffer logging:  level debugging, 38 messages logged, xml disabled,
                     filtering disabled
    Logging Exception size (4096 bytes)
    Count and timestamp logging messages: disabled
    Persistent logging: disabled

No active filter modules.

ESM: 0 messages dropped

    Trap logging: level debugging, 47 message lines logged

Log Buffer (51200 bytes):

*May 20 03:34:42.247: %VPN_HW-6-INFO_LOC: Crypto engine: onboard 0  State change
d to: Initialized
*May 20 03:34:42.251: %VPN_HW-6-INFO_LOC: Crypto engine: onboard 0  State change
d to: Enabled
*May 20 03:34:44.467: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthern
et0/0, changed state to down
*May 20 03:34:44.467: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthern
et0/1, changed state to down
000005: *May 20 11:34:45.507 PCTime: %SYS-6-CLOCKUPDATE: System clock has been u
pdated from 03:34:45 UTC Sun May 20 2012 to 11:34:45 PCTime Sun May 20 2012, con
figured from console by console.
000006: *May 20 11:34:46.263 PCTime: %SYS-5-CONFIG_I: Configured from memory by
console
000007: *May 20 11:34:48.619 PCTime: %LINEPROTO-5-UPDOWN: Line protocol on Inter
face FastEthernet0/0, changed state to up
000008: *May 20 11:34:48.619 PCTime: %LINEPROTO-5-UPDOWN: Line protocol on Inter
face FastEthernet0/1, changed state to up
000009: *May 20 11:34:50.539 PCTime: %SYS-5-RESTART: System restarted --
Cisco IOS Software, 1841 Software (C1841-ADVSECURITYK9-M), Version 12.4(24)T7, R
ELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2012 by Cisco Systems, Inc.
Compiled Tue 28-Feb-12 10:23 by prod_rel_team
000010: *May 20 11:34:50.543 PCTime: %SNMP-5-COLDSTART: SNMP agent on host cisco
1841 is undergoing a cold start
000011: *May 20 11:34:50.603 PCTime: %SSH-5-ENABLED: SSH 1.99 has been enabled
000012: *May 20 11:34:50.915 PCTime: %CRYPTO-6-ISAKMP_ON_OFF: ISAKMP is OFF
000013: *May 20 11:34:50.915 PCTime: %CRYPTO-6-ISAKMP_ON_OFF: ISAKMP is OFF
000014: *May 20 11:34:50.915 PCTime: %CRYPTO-6-ISAKMP_ON_OFF: ISAKMP is OFF
000015: *May 20 11:34:50.915 PCTime: %CRYPTO-6-GDOI_ON_OFF: GDOI is OFF
000016: *May 20 11:35:29.063 PCTime: %SYS-5-CONFIG_I: Configured from http by ba
se on 192.168.0.252
000017: *May 20 11:36:23.935 PCTime: %LINEPROTO-5-UPDOWN: Line protocol on Inter
face NVI0, changed state to up
000018: *May 20 11:36:33.467 PCTime: %DHCP-6-ADDRESS_ASSIGN: Interface FastEther
net0/1 assigned DHCP address 183.178.xxx.xxx, mask 255.255.254.0, hostname cisco1
841

000019: *May 20 12:08:54.491 PCTime: %LINEPROTO-5-UPDOWN: Line protocol on Inter
face FastEthernet0/1, changed state to down
000020: *May 20 12:09:05.203 PCTime: %LINEPROTO-5-UPDOWN: Line protocol on Inter
face FastEthernet0/1, changed state to up
000021: *May 20 12:09:08.443 PCTime: %DHCP-6-ADDRESS_ASSIGN: Interface FastEther
net0/1 assigned DHCP address 183.178.xxx.xxx, mask 255.255.254.0, hostname cisco1
841

000022: *May 20 15:52:15.926 PCTime: %LINEPROTO-5-UPDOWN: Line protocol on Inter
face FastEthernet0/0, changed state to down
000023: *May 20 18:17:26.206 PCTime: %LINEPROTO-5-UPDOWN: Line protocol on Inter
face FastEthernet0/0, changed state to up
000024: *May 20 18:25:38.746 PCTime: %SYS-5-CONFIG_I: Configured from console by
base on vty0 (192.168.0.252)
000025: *May 20 18:27:35.950 PCTime: %LINEPROTO-5-UPDOWN: Line protocol on Inter
face FastEthernet0/1, changed state to down
000026: *May 20 22:07:02.201 PCTime: %LINEPROTO-5-UPDOWN: Line protocol on Inter
face FastEthernet0/1, changed state to up
000027: *May 20 22:07:05.573 PCTime: %DHCP-6-ADDRESS_ASSIGN: Interface FastEther
net0/1 assigned DHCP address 183.178.xxx.xxx, mask 255.255.254.0, hostname cisco1
841

000028: *May 20 22:09:26.533 PCTime: %LINEPROTO-5-UPDOWN: Line protocol on Inter
face FastEthernet0/0, changed state to down
000029: *May 20 22:09:41.201 PCTime: %LINEPROTO-5-UPDOWN: Line protocol on Inter
face FastEthernet0/0, changed state to up
000030: *May 20 22:47:36.689 PCTime: %LINEPROTO-5-UPDOWN: Line protocol on Inter
face FastEthernet0/1, changed state to down
000031: *May 20 22:48:04.201 PCTime: %LINEPROTO-5-UPDOWN: Line protocol on Inter
face FastEthernet0/1, changed state to up
000032: *May 20 22:48:07.697 PCTime: %DHCP-6-ADDRESS_ASSIGN: Interface FastEther
net0/1 assigned DHCP address 183.178.xxx.xxx, mask 255.255.254.0, hostname cisco1
841

000033: *May 20 23:13:06.877 PCTime: %LINEPROTO-5-UPDOWN: Line protocol on Inter
face FastEthernet0/1, changed state to down
000034: *May 20 23:14:06.201 PCTime: %LINEPROTO-5-UPDOWN: Line protocol on Inter
face FastEthernet0/1, changed state to up
000035: *May 20 23:14:10.081 PCTime: %DHCP-6-ADDRESS_ASSIGN: Interface FastEther
net0/1 assigned DHCP address 183.178.xxx.xxx, mask 255.255.254.0, hostname cisco1
841

000036: *May 20 23:14:22.661 PCTime: %SYS-5-CONFIG_I: Configured from console by
base on vty0 (192.168.0.252)
000037: *May 21 02:07:47.056 PCTime: %SYS-5-CONFIG_I: Configured from console by
base on vty0 (192.168.0.252)
000038: *May 21 02:53:18.016 PCTime: %SYS-5-CONFIG_I: Configured from console by
base on vty0 (192.168.0.252)
cisco1841#

TOP

俾埋個show run 我睇丫.

TOP

本帖最後由 office2003 於 2012-5-21 21:01 編輯

Building configuration...

Current configuration : 5034 bytes
!
version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname cisco1841
!
boot-start-marker
boot system flash:c1841-advsecurityk9-mz.124-24.T7.bin
boot-end-marker
!
security authentication failure rate 3 log
security passwords min-length 6
logging message-counter syslog
logging buffered 51200
logging console critical
enable secret 5 $1$5n7B$iw9Rg57h3ZCsege672Vd/
!
no aaa new-model
clock timezone PCTime 8
dot11 syslog
no ip source-route
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.0.1 192.168.0.205
ip dhcp excluded-address 192.168.0.211 192.168.0.254
!
ip dhcp pool sdm-pool1
   import all
   network 192.168.0.0 255.255.255.0
   default-router 192.168.0.10
!
!
ip cef
no ip bootp server
ip domain name dyndns.org
!
multilink bundle-name authenticated
!
!
crypto pki trustpoint TP-self-signed-3754433512
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-3754433512
revocation-check none
rsakeypair TP-self-signed-3754433512
!
!
crypto pki certificate chain TP-self-signed-3754433512
certificate self-signed 01
  3082024C 308201B5 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 33373534 34333335 3132301E 170D3132 30353137 31353433
  35355A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 37353434
  33333531 3230819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
   551D1104 18301682 14636973 636F3138 34312E64 796E646E 732E6F72 67301F06
  03551D23 04183016 801497A2 1D3A92A0 B0D9A355 BEB73920 4E7A5F4B 691B301D
  0603551D 0E041604 1497A21D 3A92A0B0 D9A355BE B739204E 7A5F4B69 1B300D06
  092A8648 86F70D01 01040500 03818100 BCBE818E FD219C69 CFF077F5 5316D10F
  08B7F473 0A62DA94 05B4B444 22E41734 2117938F 32A82A80 DEEC8713 FAD2A65F
  7657153A 6A831A34 7E319F11 3219B1BC FAAA178B 293530BA 2D88A75D 76CFDAB8
  F05CC47F A6769F4E 6430636D 840C9F39 6B4BCD8B E50A9CCA AB922177 2C8D9BE6
  E5E8AF73 25F0AB52 14298B51 09D4874B
        quit
!
!
username cisco privilege 15 secret 5 $1$fjhkvl$KPjNbVcBKs3kjhkhm2D1od7tk0
archive
log config
  hidekeys
!
!
!
!
!
ip tcp synwait-time 10
ip ssh time-out 60
ip ssh authentication-retries 2
!
!
!
interface FastEthernet0/0
description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0$$ES_LAN$$FW_INSIDE$
ip address 192.168.0.10 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
no mop enabled
!
interface FastEthernet0/1
description $ETH-WAN$
ip address dhcp client-id FastEthernet0/1
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
no mop enabled
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
ip nat inside source list 1 interface FastEthernet0/1 overload
!
logging trap debugging
access-list 1 remark INSIDE_IF=FastEthernet0/0
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 192.168.0.0 0.0.0.255
no cdp run

!
!
!
!
!
control-plane
!
banner exec ^C
% Password expiration warning.
-----------------------------------------------------------------------

Cisco Router and Security Device Manager (SDM) is installed on this device and
it provides the default username "cisco" for  one-time use. If you have already
used the username "cisco" to login to the router and your IOS image supports the

"one-time" user option, then this username has already expired. You will not be
able to login to the router with this username after you exit this session.

It is strongly suggested that you create a new username with a privilege level
of 15 using the following command.

username <myuser> privilege 15 secret 0 <mypassword>

Replace <myuser> and <mypassword> with the username and password you want to
use.

-----------------------------------------------------------------------
^C
banner login ^CAuthorized access only!
Disconnect IMMEDIATELY if you are not an authorized user!^C
!
line con 0
login local
transport output telnet
line aux 0
login local
transport output telnet
line vty 0 4
privilege level 15
login local
transport input telnet ssh
line vty 5 15
privilege level 15
login local
transport input telnet ssh
!
scheduler allocate 20000 1000
end

cisco1841#

TOP

cisco1841#show interface
FastEthernet0/0 is up, line protocol is up
  Hardware is Gt96k FE, address is 0017.5aa3.1908 (bia 0017.5aa3.1908)
  Description: $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0$$ES_LAN$$FW_INSIDE$
  Internet address is 192.168.0.10/24
  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 2000 bits/sec, 2 packets/sec
  5 minute output rate 2000 bits/sec, 2 packets/sec
     1460 packets input, 149708 bytes
     Received 742 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     1076 packets output, 529711 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 unknown protocol drops
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
FastEthernet0/1 is up, line protocol is up
  Hardware is Gt96k FE, address is 0017.5aa3.1909 (bia 0017.5aa3.1909)
  Description: $ETH-WAN$
  Internet address is 183.178.xxx.xxx/23
  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:19, output 00:00:02, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     144 packets input, 9270 bytes
     Received 133 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     324 packets output, 20556 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 unknown protocol drops
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
NVI0 is up, line protocol is up
  Hardware is NVI
  Interface is unnumbered. Using address of FastEthernet0/0 (192.168.0.10)
  MTU 1514 bytes, BW 56 Kbit/sec, DLY 5000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation UNKNOWN, loopback not set
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
cisco1841#

TOP

你試下係configuration mode 行"no int nvi0"

TOP

好的,thanks師兄

TOP

個interface nvi0 應該係你之前用pxxw 既pppoe 時create 出黎, 依加佢唔應該存在既.

TOP

本帖最後由 office2003 於 2012-5-22 14:33 編輯

但我係reset to default(10.10.10.1)再從新setup的

TOP