Whatsapp "package file is invalid"

1 月1日後強迫 update,update 唔到。試過以下全都唔得
--remove folder再裝(/sdcard/whatsapp)
--clear cache再裝
--clear data再裝
--uninstall再裝
--upgrade ROM再裝 (Cyanogen mod CM11 M12  選用ART)

幾個月前遇過同樣問題,當時好似upgrade ROM後OK。今次唔得。
有冇計?

機係Nexus4