[操作疑難] NAS 有 hot swapping 都係唔好試

DS1815+ , 本先插左 5 隻 6TB WD red , 行 raid6
上兩星期買多隻 6T 加入去 , 見 syno 官網話 support hotswapping ,
就懶有型唔熄機就咁隊入去 ! 一隊 , NAS 慘叫 ! disk 1 著黃燈
入 DSM 睇 , i/o error + bad sector ! reboot 後 , 試下 rebuild , 又起得返
幾日後 ............ 都係捱唔到 , 再次慘叫 ! 即撲出去買多隻 6T :<

另又讚下 VST 個 Vcare 保養服務 ,
網上入個 s/n 就安排上門收件 , check 過係壞包一換一

本帖最後由 pc1668 於 2015-5-5 12:33 編輯

I just don't care what the manufacturer would say, won't try/test the hotswap feature ... unless it's inevitable

TOP

我好彩,試過幾次都冇事

(Sent from EPC Pocket iPhone app)

TOP

係咪根本隻DISK1 有問題?你一加碟,佢先再從檢查一次,先發現問題

TOP

Tried many times on Qnap 453 and has no problem

TOP

師兄你平時冇做開 data scrubbing?

TOP

rebuild起得翻, 過幾日又挨唔到
似係真係壞HDD, 唔關部NAS事喎

TOP

講真,我自己都玩左部機四年,大大話話hot swap左十幾隻hard disk都無事……

我諗可能係因為你一插果陣時,個disk array會停一停,可能就停果下detect到個array有問題。照樓上建議定期做scrubbing對你部機有幫助……

https://wiki.archlinux.org/index.php/RAID

List你個RAID,包括本身DSM個firmware會裝落每一隻hard drive度(i.e.: md0, md1):
cat /proc/mdstat

scrub disk:
echo check > /sys/block/md2/md/sync_action

stop scrubbing:
echo idle > /sys/block/md0/md/sync_action

TOP

回覆 8# tingcrab

依個情況應該唔關事
似係stop完再start果隻hdd爆error...
簡單d講,hdd一早有問題

(Sent from HKEPC iPhone app)

TOP

本帖最後由 diedieceo 於 2015-5-5 22:23 編輯

感激各位指導 , 啱啱返到屋企即做一次 data scrubbing 先 !

其實部 DS1815+ 同推 6T hdd 買左未夠一個月 , 理應冇咁快炒 hdd ,
為有懷疑係 hot swapping 時令資料出錯吧

之前用過兩部 syno 都冇咁快炒 HDD
印像中 CS407e 時代 raid 5 用過 WD 640GB x 4 同 WD 1.5TB Green x 4   , 三年冇炒過
DS1010+  raid 5 用 Hitachi 2TB x 5 , 四年左右炒過一隻 , 換 WD 2TB red 起得返
DX510   raid 5 用 WD 2TB Green x 5 ,  三年左右又炒過一隻 , 又係換 WD 2TB red 又起得返

所以今次未夠一個月就炒真係好黑仔
VST 今日上門收左隻 6T 走了 , 唔知佢會換返隻咩俾我呢

TOP