Totem + PPStream & Sopcast (the Ubuntu way)

本帖最後由 quintus 於 2010-1-25 02:18 編輯

Add the following PPA to /etc/apt/sources.list
e.g.
  1. deb http://ppa.launchpad.net/portis25/ppa/ubuntu lucid main
  2. deb-src http://ppa.launchpad.net/portis25/ppa/ubuntu lucid main
複製代碼
Then add the key
  1. sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys B3EAC8D9
複製代碼
or you can add the PPA in a single line command
  1. sudo add-apt-repository ppa:portis25
複製代碼
and install the packages
  1. sudo aptitude update
  2. sudo aptitude install gst-plugins-pps gst-plugins-sopcast libpps libppswrapper sopcast sopcast-player totem-pps totem-sopcast
複製代碼
After that, enable the Totem plugins


Now, we have the Sopcast and PPStream Totem sidebars



Enjoy!

Ref.
https://launchpad.net/~portis25/+archive/ppa
http://code.google.com/p/totem-pps/
http://code.google.com/p/totem-sopcast/

--edit--
Just a reminder that some of the components in the PPA contain closed source binaries.
(libpps* in libpps, sp-sc-auth in sopcast)

Fix an error in the packages installation command
附件: 您需要登錄才可以下載或查看附件。沒有帳號?註冊

wow, great !
Thanks for sharing.

TOP

fully open source implementation?

TOP

Since my notebook is running Debian sid amd64, I have rebuilt the
packages (except sopcast-player which I do not use) for my machine.  
You may get them from
http://www.hkpcug.org/~quintus/Linux/Debian/totem/
if you are also using Debian sid amd64.

TOP

fully open source implementation?
davidtlwong 發表於 2010-1-24 22:42

No, please refer to my newly added note at the bottom of post #1.

TOP

No, please refer to my newly added note at the bottom of post #1.
quintus 發表於 2010-1-24 22:54



    a bit disappointing. I saw the gst plugin is in GPL license, with close sourced library, it is quite a license problem.

TOP

Thanks.

TOP

Add the following PPA
e.g.Then add the keyand install the packagesAfter that, enable the Totem plugi ...
quintus 發表於 2010-1-24 18:24


第一個係要改FILE, 唔係行COMMAND.
在 /etc/apt/sources.list 最尾地方加呢兩句.

第三個應該係行 sudo apt-get install ..........
唔係就咁 sudo aptitude ........

TOP

a bit disappointing. I saw the gst plugin is in GPL license, with close sourced library, it i ...
davidtlwong 發表於 2010-1-24 23:47


Same here.
BTW, that's why they use a wrapper library to wrap up libpps*.

TOP

第一個係要改FILE, 唔係行COMMAND.
在 /etc/apt/sources.list 最尾地方加呢兩句.

第三個應該係行 sudo a ...
electronic_s 發表於 2010-1-25 01:15


已修正,多謝指出錯處。

TOP