CentOS 5 Kernel 新手問題

我一直都係用緊 Kernel 2.6.18-128.7.1 ...
前日用 yum 更新左 Kernel 去最新版本 2.6.18-128.11.1
但係今日 Reboot 部機 ...
發現 2.6.18-128.7.1 個 File Remove 左 ...
但 CentOS Kernel 仲係用緊 2.6.18-128.7.1
而唔係用緊最新既 Kernel 2.6.18-128.11.1
令部機唔可以正常運作 ...
請問點先可以令 CentOS 用最新既 Kernel ?

粗人方法,

check 下 /lib/modules 有 kernel version
mount /boot
ls 目標 kernel
都到位
edit grub
save , umount /boot
reboot



good luck ++

TOP

粗人方法,

check 下 /lib/modules 有 kernel version
mount /boot
ls 目標 kernel
都到位
edit grub
save ...
killerpub 發表於 2010-1-27 03:59

唔該哂 =]
另外我有個問題想問問...
如果我換哂底板 , CPU 個 Linux 需唔需要重新安裝過 ?

TOP

本帖最後由 icarus-c 於 2010-1-27 17:41 編輯

回復 3# trendhk


    唔需要, 因為有冇換過hardware都係開機時先probe drivers

TOP

係唔係唔需要,係取決於新 hardware config 係唔係 modules 都到位。

custom kernel 多少會有 performance gain ?

TOP

回復 5# killerpub


    a lot :P  faster boot & binary optimization (unless you don't build with -march=native)

TOP

build with "native", can't use distcc

TOP

回復 2# killerpub


用緊 centos 5.3 i386  kernel 2.6.18-128.el5 想轉用 2.6.30.3

行 make modules 都有以下呢d error message, 應該可以點搞?

CC [M]  drivers/gpu/drm/via/via_irq.o
  CC [M]  drivers/gpu/drm/via/via_drv.o
  CC [M]  drivers/gpu/drm/via/via_map.o
drivers/gpu/drm/via/via_map.c: In function ‘via_map_init’:
drivers/gpu/drm/via/via_map.c:92: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
The bug is not reproducible, so it is likely a hardware or OS problem.
make[4]: *** [drivers/gpu/drm/via/via_map.o] Error 1
make[3]: *** [drivers/gpu/drm/via] Error 2
make[2]: *** [drivers/gpu/drm] Error 2
make[1]: *** [drivers/gpu] Error 2
make: *** [drivers] Error 2

TOP

回復 8# tarekohk

if you are not using via's gpu, you can deselect that module before compilation.

TOP

回復 9# sunlite

thanks

TOP