mounting a win7 share drive to linux

I found this problem not only happen for linux world (android, raspberry Pi, debian etc..)..

I have a win7 PC, with 5 HDD in it. and they all share out:
HDD1 MBR
HDD2 MBR
HDD3 GPT,
HDD4 MBR
HDD5 MBR

I found I can only mount the HDD3 successfully, and the same config just can't mount the rest MBR HDDs, however access from another windows PC is totally ok.

when I tried to mount those MBR HDDs, I got the error(5) message:
pi@Raspyfi:/home$ sudo mount -a
mount error(5): Input/output error
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

Using the same command/config for MBR HDD just won't work..
any Ching here met and solved the same problem? can you share a bit?

Thanks!

Are you using Windows 7's Network share? If yes, use mount.cifs.

TOP

回覆 2# 4c39


    yes. but why one of the drives can mount successfully while the rest just can't make it? this really bothers me..

TOP

回覆 1# ciscotomx

please also post your fstab

TOP

本帖最後由 ciscotomx 於 2014-12-17 20:13 編輯

回覆 4# sunlite


    my fstab looks like this:

/dev/mmcblk0p3 /               ext4    noatime,nouser_xattr,errors=remount-ro 0   1
/dev/mmcblk0p1  /boot        vfat    utf8            0       0
Ramdisk   /run/shm        tmpfs   defaults,size=256M,noexec,nodev,nosuid       0   0
//192.168.1.28/e      /home/pi/NAS/Music      cifs    sec=ntlm,username=NAS,password=xxx,_netdev,dir_mode=0777,file_mode=0777      0       0
//192.168.1.28/f      /home/pi/NAS/pdf         cifs    sec=ntlm,username=NAS,password=xxx,_netdev,dir_mode=0777,file_mode=0777      0       0

when I run mount -a
pi@Raspyfi:~$ sudo mount -a
mount error(5): Input/output error
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
pi@Raspyfi:~$

only //192.168.1.28/e got mount successfully

TOP

回覆 5# ciscotomx

please also post the output of
$ smbclient -L 192.168.1.28
   
You can cut out other unrelated stuff.

TOP

提示: 作者被禁止或刪除 內容自動屏蔽

TOP

回覆 6# sunlite


    pi@Raspyfi:~$ sudo smbclient -L 192.168.1.28
WARNING: The security=share option is deprecated
Enter root's password:
session request to 192.168.1.28 failed (Called name not present)
session setup failed: NT_STATUS_LOGON_FAILURE

eh.. how to use the username option?

TOP

回覆 7# toylet


    funny thing is, even I did nothing, now HDD3 can't mount, and HDD2 mount successfully..

TOP

回覆 8# ciscotomx

You don't need to enter the root password, there is an anonymous mode if you just press enter for  the password prompt.

TOP