GUI 問題

本帖最後由 milanolarry 於 2015-5-5 09:05 編輯

裝左 Gnome 之後每次 boot 機都會直入 Gnome,想問下如果想 boot 機後只係入 text mode 而吾入 Gnome 應該改邊度同點改?吾該先。我用 Debian 7。

1. 以 root 身份編輯 /etc/inittab
2. 在大約第 5-6 行, 修改:
id:x:initdefault: -> id:2:initdefault:

TOP

1. 以 root 身份編輯 /etc/inittab
2. 在大約第 5-6 行, 修改:
id:x:initdefault: -> id:2:initdefault: ...
hacker1202 發表於 2015-5-5 10:39


唔係應該改id:3:initdefault: ?
http://en.wikipedia.org/wiki/Runlevel
2        Multi-user Mode        Does not configure network interfaces and does not export networks services.[3]
3        Multi-user Mode with Networking        Starts the system normally.[4]

2的話會冇start到network

update, 原來debian 2-5一樣

TOP

本帖最後由 milanolarry 於 2015-5-5 21:27 編輯

入到去已經係    id:2:initdefault   要轉     id:1:initdefault   先入 text mode

TOP

入到去已經係    id:2:initdefault   要轉     id:1:initdefault   先入 text mode
milanolarry 發表於 2015-5-5 16:10


runlevel 1 係 single user mode,呢个 mode 下好多 service 预设不会啟动,唔建议咁用
我自己无用 gnome,唔太清楚,但你可以试下改 gdm(或其 counterpart)係 runlevel 2 时唔啟动就可以。

Ref.: https://wiki.debian.org/RunLevel

TOP

另外提一提,debian 8 已 release,而且跟其他 latest distro 一样都以systemd 取代了 init,有好有唔好,不过大势所趋,都要学架啦 ~

TOP

systemctl disable gdm?

TOP

systemctl disable gdm?
lazyfai 發表於 2015-5-6 13:34


debian 8 systemd 应该係咁
debian 7 default 应该仲系 sysv-init,用返 update-rc.d 嚟做会靓仔 D ~

TOP