[操作疑難] 學language 追版本?

提示: 作者被禁止或刪除 內容自動屏蔽

呢度有詳細解釋點解 Python3 出咗咁耐,但係好多人仲用緊 Python 2。

Python3 同 2 比,分別都幾大。而家 stable version 係 3.6,已經無曬上面講嗰啲問題,可以放心學 3。

一般嚟講,响軟件嘅世界學一隻語言或者 framework,會揀最新嘅穩定版本。除咗新舊版可能唔兼容之外,通常新版本會包括一啲結構性嘅更新係舊版本做唔到/好難做到。用新版會比較容易學到新嘅 pattern。

不過,如果你個目標 runtime environment 只支持某個版本,你都係要焗住用佢支持嗰隻。

亦都因為咁,其實學 programming,除咗概念性嘅嘢可以睇書之外,同語言、library / framework 掛勾嘅最好唔好睇書。因為書係更新唔切。但基本概念識咗,其實語言同版本係完全唔重要 :)

TOP

提示: 作者被禁止或刪除 內容自動屏蔽

TOP

thanks師兄, 咁我努力D繼續學3啦
hui20299 發表於 2017-1-24 14:51


   
其實 2,3 都應該要識(打工計)

via HKEPC Ionic Reader v1.5.1 - iPhone

TOP

其實 2,3 都應該要識(打工計)

via HKEPC Ionic Reader v1.5.1 - iPhone
hihihi123hk 發表於 2017-1-25 10:54


如果由0開始學, 學左新既先
因為話唔定學到用熟左之後, 舊版已經開始淘汰
真係到main舊system時先學翻都未遲, 反正舊版D野已經唔會再變, 慢慢學都唔會跟唔上

TOP

相關文章