[測試] 有冇邊張Display 可以係ESXi GPU Passthrough正常出到Signal去個Mon?

本帖最後由 1597532468000 於 2016-12-1 23:30 編輯

我玩過ESXi 6.0 U2 同 5.5 U3a (裝左Atheros AR1851 driver)
試過晒將3粒唔同既GPU Passthrough去Win7
3粒GPU分別係 i5 3570 iGPU, HD4670, GTX460
DVI線插番落Display Card道(iGPU插onboard)
全部結果一樣
Win7 VM係Device manager入面搵到兩張Display card
一張係VMware SVGA另一張係Passthrough入去果張
但係裝唔裝真卡既Driver都係出唔到Signal比個Mon
係Screen Resolution都只係得一個VM既Mon搵唔到個真Mon
裝Win10一樣冇Signal仲要一裝Driver就BSOD -> reboot
行Ubuntu live cd開機果時會有Signal 但係入到Desktop個Signal就會Freeze左冇野睇

有冇c-hing有玩ESXi Display Passthrough可以分享下用咩版本, MB同Display Card?

我部機既Config:
i5-3570 4.2GHz (non-k OC 4+4)
Gigabyte GA-Z77MX-D3H
10GB DDR3 1600
Intel HD Graphics 2500 / ATI HD4670 512MB / Nvidia GTX460 1GB
149GB Virtual Disk for VM OS
8GB SD Card for ESXi OS


本帖最後由 ykwong08 於 2016-12-1 20:51 編輯

注意,我印象中,這是浪費時間的。

事實上,只有官方認可的 專業display card,才可以完美的passthrough.

所有平常買到的 display card, 他們只是巧合地 用到一次/2次 passthrough, 之後又要全機reboot後,再可以passthrough。

TOP

我印象中 ESXI 5.1 +AMD GPU

TOP

esxi無用過答唔到你
如果host無要求係win7+esxi
可以試下fedora+qemu
我而家guset win10無太大問題

TOP

5.5 win7 hd5770 hd6770 成功過
asrock z87,關iGPU,關onboard sound card
聽講iGPU一定要係bios關,同一定passthrough唔到
印像中裝win7前已經要插住卡同mon,
如果唔係會搵唔到隻mon或者之後插就藍mon(可能只係我/驅動問題)

TOP

本帖最後由 1597532468000 於 2016-12-1 22:43 編輯
esxi無用過答唔到你
如果host無要求係win7+esxi
可以試下fedora+qemu
我而家guset win10無太大問題 ...
ice.fire 發表於 2016-12-1 22:20


ESXi睇落唔算好難所以試下玩
我本來打算試埋xen...目的係做到一部PC行幾部VM出幾個Mon分比幾個人用
但似乎要將GTX460改成Quadro 4000M先做到Passthrough
利申: 對VM唔太熟悉...只係玩過Virtualbox, VMware同岩岩開始玩既ESXi

TOP

5.5 win7 hd5770 hd6770 成功過
asrock z87,關iGPU,關onboard sound card
聽講iGPU一定要係bios關,同一定pa ...
537923 發表於 2016-12-1 22:35



我試過BIOS熄iGPU...但冇熄到Audio
熄左iGPU由開機果下Display card都插住Mon有ESXi畫面
直到set好passthrough...boot起隻VM果下個Mon就會冇Signal(似乎已經比VM搶左張Display既控制)
一直到裝好Win7同Display driver都係冇Signal好似上圖咁
如果熄Audio都唔得我諗要試埋5.0同5.1

TOP

補充一點
我係先係VMware Player上面裝ESXi落SD Card入面...再裝埋LAN Driver
之後再插落真機boot入SD Card入面既ESXi...唔知會唔會因為轉過機所以令passthrough失敗

用VMware Player原因: ESXi 唔support Atheros LAN 一定要裝driver
之前用ESXi-Customizer加左driver落去6.5既iso再燒碟...裝落SD Card果下先發覺裝唔到
唔想次次燒左隻碟出黎又裝唔到...又冇多隻手指比我做裝機碟...所以搵VMware幫手裝定先

TOP

回覆 8# 1597532468000


我覺得應該唔關事,
我都試過搬機,只要重tick 1樓第一張圖,再reboot就ok
依加你個情況我覺得似係驅動問題,我都試過咁樣

TOP

樓主有冇試過禁 1樓第2張圖個detect制?

TOP