ICH10點樣唔駛重裝windows 開achi???(XP)

ICH10點樣唔駛重裝windows 開achi???(XP)

改 Windows registry->Install driver->BIOS enable AHCI

TOP

ICH10點樣唔駛重裝windows 開achi???(XP)
tangsunhk 發表於 2011-9-16 11:58



    windows 7 我就知 ,  http://iphonedaily.com/windows-7-ahci-enable-ahci-after-install/

TOP

若要用ahci, xp必須重裝

TOP

回復 1# tangsunhk
上次有位版友問過!!
我用圖文教過佢試過,佢都話吾得!!
但我以前用xp時都係習慣先用IDE裝xp先,
裝好xp後先至再裝返AHCI Driver,未試過話吾Work!!
如果c兄吾怕煩我再講多次點裝xp ich10 ahci driver!!!

TOP

若要用ahci, xp必須重裝
akao 發表於 2011-9-18 11:11


我xp轉ahci唔洗重裝喎.... 你搞錯晒喎....

TOP

I followed the instruction from a web site and successfully enabled AHCI on a G45 with ICH10R. I forgot the source, I just have the text file of the instructions.

If you installed Windows XP in IDE mode (without AHCI or RAID) or you installed Windows in AHCI mode and would like to switch to RAID (or from RAID to AHCI) here's what to do :

- Download the storage manager 32 bits floppy zip file and "RAID/AHCI Software - Intel® Matrix Storage Manager" on Intel website.

- Extract iaStor.sys to "C:\WINDOWS\system32\drivers"

- Create a file named iastor-ahci+raid.reg and copy this content into it :

--------------------------------------------
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\CriticalDeviceDatabase\pci#ven_8086&dev_3a22&cc_0106]
"ClassGUID"="{4D36E96A-E325-11CE-BFC1-08002BE10318}"
"Service"="iaStor"

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\CriticalDeviceDatabase\pci#ven_8086&dev_2822&cc_0104]
"ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
"Service"="iaStor"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStor]
"Type"=dword:00000001
"Start"=dword:00000000
"Group"="SCSI Miniport"
"ErrorControl"=dword:00000001
"ImagePath"="system32\\drivers\\iaStor.sys"
"tag"=dword:00000019
"DisplayName"="Intel AHCI+RAID Controller"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStor\Parameters]
"queuePriorityEnable"=dword:00000000
"BusType"=dword:00000003

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStor\Parameters\Port0]
"AN"=dword:00000000
"LPM"=dword:00000000
"LPMSTATE"=dword:00000000
"LPMDSTATE"=dword:00000001
"GTF"=dword:00000000
"DIPM"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStor\Parameters\Port1]
"AN"=dword:00000000
"LPM"=dword:00000000
"LPMSTATE"=dword:00000000
"LPMDSTATE"=dword:00000001
"GTF"=dword:00000000
"DIPM"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStor\Parameters\Port2]
"AN"=dword:00000000
"LPM"=dword:00000000
"LPMSTATE"=dword:00000000
"LPMDSTATE"=dword:00000001
"GTF"=dword:00000000
"DIPM"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStor\Parameters\Port3]
"AN"=dword:00000000
"LPM"=dword:00000000
"LPMSTATE"=dword:00000000
"LPMDSTATE"=dword:00000001
"GTF"=dword:00000000
"DIPM"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStor\Parameters\Port4]
"AN"=dword:00000000
"LPM"=dword:00000000
"LPMSTATE"=dword:00000000
"LPMDSTATE"=dword:00000001
"GTF"=dword:00000000
"DIPM"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStor\Parameters\Port5]
"AN"=dword:00000000
"LPM"=dword:00000000
"LPMSTATE"=dword:00000000
"LPMDSTATE"=dword:00000001
"GTF"=dword:00000000
"DIPM"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStor\Enum]
"0"="PCI\\VEN_8086&DEV_3A22&SUBSYS_B0051458&REV_00\\3&13c0b0c5&0&FA"
"1"="PCI\\VEN_8086&DEV_2822&SUBSYS_B0001458&REV_02\\3&13c0b0c5&0&FA"
"Count"=dword:00000002
"NextInstance"=dword:00000002
---------------------------------------------------------

- Reboot and change the mode to IDE, AHCI or RAID in the BIOS. If you were using a RAID to boot make sure that you know what you do before rebooting, taking apart a RAID will likely break your windows installation.

- When you're back in Windows, install the "RAID/AHCI Software - Intel® Matrix Storage Manager" to finish the process.

Please note that I haven't tested this on any other hardware than my GA-EP45-DS4P motherboard from Gigabyte, but any P45 + ICH10 motherboard should work, as usual make a backup of your data before trying this!!! Changing the registry (particurarily the part that is responsible for the drivers required to boot) can lead to an unbootable OS, you've been warned!

Before you do this if you are booting in AHCI or RAID mode you should have one of the following registry key :

------------------------AHCI------------------------
[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\CriticalDeviceDatabase\pci#ven_8086&dev_3a22&cc_0106]
"ClassGUID"="{4D36E96A-E325-11CE-BFC1-08002BE10318}"
"Service"="iaStor"

------------------------RAID------------------------
[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\CriticalDeviceDatabase\pci#ven_8086&dev_2822&cc_0104]
"ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
"Service"="iaStor"

If you don't have one of those keys and you're using AHCI or RAID you don't have the same ICH10 chip as me and should try to replicate my changes with the right ClassGUID and PCI Ids.

TOP

回復 6# myricky

你係正確的

http://forums.pcper.com/showthread.php?t=444831

TOP

我都有這問題   謝

TOP

回復 7# law_so

我照住你方法整, 成功了, 謝謝

TOP

相關文章