我跟以下 procedure 安裝 , 但遇上問題

本帖最後由 peterchu1 於 2010-1-18 20:42 編輯

我跟以下 procedure 安裝 , 但遇上問題  

http://blazonry.com/scripting/install_apache.php



1 ) 當 compile apache 時
# ./configure --prefix=/usr/local/apache \
    --enable-module=rewrite \
    --activate-module=src/modules/php4/libphp4.a

就出以下訊息
./configure --prefix=/usr/local/apache \ --enable-m
odule=rewrite \ --activate-module=src/modules/php4/libphp4.a
Configuring for Apache, Version 1.3.41
+ using installation path layout: Apache (config.layout)
configure:Error: invalid option ' --enable-module=rewrite'


2 ) 當 compile install php 時
make

"
o sapi/apache/mod_php4.lo sapi/apache/php_apache.lo main/internal_functions.lo -
lcrypt -lcrypt -lresolv -lm -ldl -lnsl -lcrypt -lcrypt  -o libphp4.la
ext/pcre/pcrelib/pcre_chartables.lo: file not recognized: File truncated
collect2: ld returned 1 exit status
make: *** [libphp4.la] Error 1
"

make install
"
_multibyte.lo Zend/zend_strtod.lo Zend/zend_execute.lo sapi/apache/sapi_apache.l
o sapi/apache/mod_php4.lo sapi/apache/php_apache.lo main/internal_functions.lo -
lcrypt -lcrypt -lresolv -lm -ldl -lnsl -lcrypt -lcrypt  -o libphp4.la
ext/pcre/pcrelib/pcre_chartables.lo: file not recognized: File truncated
collect2: ld returned 1 exit status
make: *** [libphp4.la] Error 1
"

之後都起到 apache , 但就唔可以行 phpinfo.php ,  請問咩原因啊 ? thx

ps.
php 4.4.9
apache 1.3.41

any reason why do you prefer to configure&make instead of using distribution pre-built package or at least build a package?

TOP

any reason why do you prefer to configure&make instead of using distribution pre-built package or at ...
icarus-c 發表於 2010-1-19 01:59



      裝  pre-built package 唔係冇咁好咩 ?

TOP