mod BIOS 加 NVMe 支援遇到問題

跟從 win-raid 的教學成功改完 BIOS 並 FLASH
但係…

1) 首次開機一定搵唔到 Windows Boot Manager,一定要 reboot 一次先見到。Reboot 又消失左,再 reboot 又見番。
1) 即係凡 boot 機單次數就見唔到, boot 機雙次數就見到。

2) 淨插 NVMe SSD 係 BIOS 內必定見唔到 Windows Boot Manager,必須要跟最少一件 SATA 先會出現 1) 所述的情況。

希望有師兄指點下。
謝謝。

MB: Biostar Hi-Fi B85N 3D v5.0
BIOS: B85AIB24.BSS (最新)

唔肯定,但可以試吓用bcdboot 打個windows boot manager 落隻sata碟叫佢boot隻NVMe得唔得,得就用得唔好煩

TOP

我試下
thank you

TOP

回覆 1# dos2vista

試試在這設定方面作出調整!
SNAG-0001.jpg
2021-4-3 10:06

TOP

首先多謝回應的兩位師兄。

試了多次,抱括使用另一款 NVMe 和轉接卡。發現:

1A) 單次數 BOOT 機,偵測 SATA 時嚴重延遲(以出現 Detected ATA/ATAPI Devices... 的文字為準)
Fail Post.jpg
2021-4-4 10:31

1B) 偵測 PEX16_1 Slot 的 Gen X 必定出錯,不論是否鎖定 PEX16_1 Slot 為 Gen3。
1B) 通常是偵測成 x4 Gen2,偶爾更偵測成 x4 Gen1!
Fail PCIE.jpg
2021-4-4 10:31


Fail Boot.jpg
2021-4-4 10:31



2A) 雙次數 BOOT 機,偵測 SATA 時馬上成功(以出現 Detected ATA/ATAPI Devices... 的文字為準)
Success Post.jpg
2021-4-4 10:32

2B) 偵測 PEX16_1 Slot 的 Gen X 正確為 x4 Gen3(必須鎖定 PEX16_1 Slot 為 Gen3)
2B) Auto 只會偵測成 x4 Gen2!
Success PCIE.jpg
2021-4-4 10:32

Success Boot.jpg
2021-4-4 10:32


結論:

1) 單次數 boot 機 BIOS 內必定找不到 NVMe,那怕是使用二樓師兄提供的方法。
1) 可能是 BIOS 或底板上的偵測問題。死症!?


2) 跟之前 2) 所述無關。
2) 淨插 NVMe SSD 係 BIOS 內必定見唔到 Windows Boot Manager,必須要跟最少一件 SATA 先會出現 1) 所述的情況。


此板要用 NVMe boot 機只能開機後 reboot 並按 F9 叫出 boot 機選單選 Windows Boot Manager。
很麻煩……

TOP

會唔會有咩timer可以set 長啲俾佢有時間detect?

TOP

求其睇可能呢幾個可以試試
PCI latency timer, SATA self test, primary PCIE

TOP

唔肯定,但可以試吓用bcdboot 打個windows boot manager 落隻sata碟叫佢boot隻NVMe得唔得,得就用得唔好煩 ...
ckyuen2 發表於 2021-4-2 16:43



    使唔使裝windows 落sata 碟 ??

TOP

本帖最後由 eric226 於 2021-4-4 19:51 編輯

回覆 5# dos2vista

試試用這設定!黃色字部份set disable!但如果你是用PCI加NVMe的話,就要set other PCI Devic Rom set UEFI!
是否用內顯?
SNAG-0000.jpg
2021-4-4 19:16

TOP

本帖最後由 eric226 於 2021-4-4 19:37 編輯

另外有冇set jumper?
SNAG-0002.jpg
2021-4-4 19:34

TOP