upgrade php

我以家用緊一個低個5.2既php版本......因為我run phpmyadmin時話我要5.2或以上

我check唔到個php咩version...因為我用 <? phpinfo(); ..... 出了一個空白的畫面

我嘗試在 CentOS 個terminal 用 "yum update php" 又話無新update...所以我上了php.net下載左最新5.2.8落來

不過我唔識安....有無人識點update 個php去 5.2.8啊....謝謝

phpinfo 出空白畫面? 會唔會係熄o左 short tag? 試吓

<?php phpinfo(); ?>

睇吓出唔出到?

TOP

http://bluhaloit.wordpress.com/2 ... t-es5-centos-5-etc/

暫時佢俾倒 5.2.6。

[ 本帖最後由 KZ4977 於 2008-12-24 22:14 編輯 ]

TOP

原帖由 KZ4977 於 2008-12-24 21:54 發表
http://bluhaloit.wordpress.com/2008/03/13/installing-php-52x-on-redhat-es5-centos-5-etc/

暫時佢俾倒 5.2.6。

No已經出到5.2.8-1
要睇緊係睇官網啦,雖然係法文..
http://blog.famillecollet.com/post/2008/12/09/php-5.2.8-1

PS: 如果你本身係PHP4+MYSQL4 ..佢應該要你連MYSQL 都要升級做5

TOP

原帖由 foobar 於 2008-12-24 14:53 發表
phpinfo 出空白畫面? 會唔會係熄o左 short tag? 試吓



睇吓出唔出到?



都係空白.....真係好奇怪

php就一定run緊....因為舊版 phpsysinfo 正常...新版就鬧我要5.2或以上

TOP

原帖由 Wai 於 2008-12-24 10:49 PM 發表

No已經出到5.2.8-1
要睇緊係睇官網啦,雖然係法文..
http://blog.famillecollet.com/post/2008/12/09/php-5.2.8-1

PS: 如果你本身係PHP4+MYSQL4 ..佢應該要你連MYSQL 都要升級做5

我指示 CentOS o既 yum 佢更新但係佢 retrieve 唔倒o既?

[ 本帖最後由 KZ4977 於 2008-12-24 23:30 編輯 ]

TOP

原帖由 KZ4977 於 2008-12-24 23:30 發表

我指示 CentOS o既 yum 佢更新但係佢 retrieve 唔倒o既?



剛剛再試多左一次個 yum update php

好像 retrieve 左 5.1.6 返來

TOP

原帖由 KZ4977 於 2008-12-24 23:30 發表

我指示 CentOS o既 yum 佢更新但係佢 retrieve 唔倒o既?

佢有一個yum 的rpm 要裝左,先可以拎到佢d rpm

TOP

如果要update...首先要跟返os dl返佢個rpm..,之後再裝左d rpm佢
http://blog.famillecollet.com/pages/Config-en

ok左之後呢..就行句yum --enablerepo=remi update php 就得架啦
ps: 如果本身係mysql4 就要打yum --enablerepo=remi update php mysql,佢會一次過升做mysql5,因為佢個php_mysql個d rpm 只係support php5+mysql5

記住..如果第日要裝d phpGD, php_mbstring  之類,住部都要yum --enablerepo=remi 先可以拎到野

[ 本帖最後由 Wai 於 2008-12-25 00:39 編輯 ]

TOP

原帖由 Wai 於 2008-12-25 12:35 AM 發表

佢有一個yum 的rpm 要裝左,先可以拎到佢d rpm

宜家就係行緊佢出o既 5.2.6,platform 分別係 CentOS 5.2 同 RHEL 5.2 兩者都有。

打完指令後發覺話無 update for php。

[ 本帖最後由 KZ4977 於 2008-12-25 01:20 編輯 ]

TOP