[REOPEN] ubuntu 10.04 64bit - Magic-pro ProHDTV Dual (USB)

本帖最後由 hmuskie 於 2010-8-16 11:41 編輯

Hybrid DMB-H/Analog TV Stick

I have spent couple days to make that work but with no joy.

I also gone thru:

http://www.hkepc.com/forum/viewthread.php?tid=1451730&page=2

Again, get stuck while compiling:

  CC [M]  /home/muskie/v4l-dvb/v4l/stv06xx_st6422.o
  CC [M]  /home/muskie/v4l-dvb/v4l/sunplus.o
  CC [M]  /home/muskie/v4l-dvb/v4l/t613.o
/home/muskie/v4l-dvb/v4l/t613.c: In function 'sd_setfreq':
/home/muskie/v4l-dvb/v4l/t613.c:1330: error: implicit declaration of function 'setfreq'
make[3]: *** [/home/muskie/v4l-dvb/v4l/t613.o] Error 1
make[2]: *** [_module_/home/muskie/v4l-dvb/v4l] Error 2
make[2]: Leaving directory `/usr/src/linux-headers-2.6.32-23-generic'
make[1]: *** [default] Error 2
make[1]: Leaving directory `/home/muskie/v4l-dvb/v4l'
make: *** [all] Error 2


Any idea?

Thanks!

你試下改 v4l/.config
CONFIG_USB_GSPCA_T613=m
->
CONFIG_USB_GSPCA_T613=n

TOP

I've just built a kvm ubuntu 10.4 32-bit virtual machine with kernel 2.6.32-24-generic, and tried the compilation of asus_u3100_20100523.tar.gz. No problem was found except the known error for firedtv, for which you need to change 'v4l/.config for the line:

CONFIG_DVB_FIREDTV=m

to

CONFIG_DVB_FIREDTV=n

TOP

回復 3# ksng

我相信樓主係用左 latest hg source 來 compile, 我 pull 左黎試
除左 T613, 仲要處理
CONFIG_IR_MCEUSB=m
->
CONFIG_IR_MCEUSB=n

TOP

回復  ksng

我相信樓主係用左 latest hg source 來 compile, 我 pull 左黎試
除左 T613, 仲要處理
CONFIG ...
netter 發表於 2010-8-12 23:16

I see! But the HG source does not support Magic-pro ProHDTV Dual. Only my private version downloadable from sendspace supports it.

TOP

RE: (SOLVED) ubuntu 10.04 64bit - Magic-pro ProHDTV Dual (USB)

ksng and everyone,

I downloaded the source from and MAKE it.

[url]http://linuxtv.org/hg/~mkrufky/dmbth/

[/url]

It was because google pointed me to there and someone sent the Magic-Pro's tuner patch to mkrufky and he will integrate it. Unfortunately, this can't fix the problem as I got the error mentioned about.

So, google and google again, until very late last night found this link
(that's  ksng's posted the file in there)

[url]http://www.hkepc.com/forum/viewthread.php?tid=1451730

[/url]

So, try to download the source that's from sendspace. Do a MAKE, edit the "CONFIG_DVB_FIREDTV", MAKE, MAKE INSTALL.

Then everything works like a charm!

At last, thanks ksng and everyone that contributed.

Cheers!

TOP

I just realized both HD ATV and HD TVB have the sound issue. The rest of the channels are fine.

Well, I use Kaffeine, when I switched to those 2 channels, I could hear the sound for about 2 seconds and then disappear. (Video got a bit lag but still fine)

My cpu is:
product: Pentium(R) Dual-Core CPU       T4300  @ 2.10GHz

And their CPU% are over 90 for those 2 channels. The rest channels are just about 50.

Is it because of my cpu not powerful enough? Any hardware accelerator need to enable?

Thanks!

TOP

回復 7# hmuskie

你果粒應該係 notebook cpu
硬解要睇 display card 的, 你部 notebook 有冇獨立顯視卡?

TOP

netter,

You are correct, it's a low-end notebook and I just put in 4GB RAM.

Since that's a cheap one, don't have the luxury that with a individual display. It's a:

Integrated Mobile Intel Graphics Media Accelerator X4500MHD with Intel Clear Video Technology and DVMT 5.0 delivers low-power, high-performance 2D/3D graphics with Shader Model 4.0 and DirectX 10.0, video and display capabilities at a maximum shared memory of 384MB.

TOP

回復 9# hmuskie
On linux, there's hardware x264 acceleration based on VDPAU or VAAPI. VDPAU requires Nvidia display card. I'm not sure if VAAPI works with Intel GMA X4500HD or not:

http://www.phoronix.com/forums/showthread.php?t=22883#post119401

TOP