Ubuntu 10.10 Chinese input problem~ Help!

本帖最後由 botherguy 於 2010-10-18 10:25 編輯

Recently I updated/installed Ubuntu 10.10, the default chinese input is ibus. But iBus has serious problem in this version of ubuntu, it will causing CPU 100%. Another issue is CangJie 3, I cannot input some chinese character with same cangjie code in previous ubuntu 10.04.

So I decided to change the input method to scim, I installed scim and make sure that all scim packages are installed. However, I cannot switch to chinese input (ctrl + space), I think the problem is my ubuntu using english UI. After conducted google which still no resolution found(or I don't understand...).

Help~!

please google search im-switch

TOP

試下係~/.xprofile加以下既野然後logout/in:
  1. # SCIM
  2. export XMODIFIERS=@im=SCIM
  3. export GTK_IM_MODULE="scim"
  4. export QT_IM_MODULE="scim"
  5. export XIM_MODULE="scim -d"
  6. #export LC_CTYPE=en_US.UTF-8
  7. scim -d
複製代碼

TOP

I got the same problem as well. I wonder if it is the same bug as described in https://code.google.com/p/ibus/issues/detail?id=625

TOP

本帖最後由 thhui 於 2010-10-18 22:30 編輯

試試安裝 gcin.

在 Terminal 終端機 打
sudo aptitude install gcin

裝完之後
在 Language Setting Set 用 Gcin (不再用 ibus) 做 default 輸入法。

再 Reboot 機
就可以禁Ctl-Alt-1 打倉頡

詳情請看
http://cle.linux.org.tw/trac/wiki

http://cle.linux.org.tw/gcin/download/#_debian

TOP

我用 lubuntu 10.10 我暫時沒有 ibus 問題。我是安裝好 系統繁體中文支援包 系統用繁體中文 安裝了倉三,倉五,速成,廣東話,沒有改動 ~/.xprofile
未遇過 ibus 令到 100% cpu 情況

TOP

本帖最後由 botherguy 於 2010-10-19 16:36 編輯
please google search im-switch
Bomber 發表於 2010-10-18 13:32


im-switch -s scim

No system wide default defined just for locale en_HK

我用 lubuntu 10.10 我暫時沒有 ibus 問題。我是安裝好 系統繁體中文支援包 系統用繁體中文 安裝了倉三,倉 ...
zeissoctopus 發表於 2010-10-19 04:05


after I open iBus preference, then will CPU 100% even I close closed the preference window

TOP

用 gcin 啦,易用好多

TOP

用 gcin 啦,易用好多
loop7 發表於 2010-10-19 16:48


All problem solved and I am using gcin right now! Thanks!

TOP

For using ibus in en_* locales (or any locales other than zh_CN* / zh_TW* ...), I have also encountered similar problem in Cangjie3.  What I have done to work around it is putting
  1. LC_CTYPE=zh_HK.UTF-8
複製代碼
into /etc/environment
and reboot

TOP