n3150 problem follow up

i don't know if i solve the "wouldn't boot" problem or not. i use another harddisk and installed archlinux with systemd-boot as boot loader. now the system can boot (i can see the light blink). however, my router did not see that server. so i disconnect the harddisk and exam the journal log.
here is the reference about the lan port :
  1. Mar 16 17:08:39 Server2 kernel: r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
  2. Mar 16 17:08:39 Server2 kernel: r8169 0000:03:00.0 eth0: RTL8168g/8111g at 0xffffc90000644000, d0:50:99:9b:5f:3e, XID 0c000800 IRQ 122
  3. Mar 16 17:08:39 Server2 kernel: r8169 0000:03:00.0 eth0: jumbo features [frames: 9200 bytes, tx checksumming: ko]
  4. Mar 16 17:08:39 Server2 kernel: r8169 0000:03:00.0 enp3s0: renamed from eth0
  5. Mar 16 17:08:42 Server2 kernel: r8169 0000:03:00.0 enp3s0: link down
  6. Mar 16 17:08:42 Server2 kernel: r8169 0000:03:00.0 enp3s0: link down
複製代碼
however, when the harddisk is connected to another motherboard with monitor (and everything) attached. the log is :
  1. Mar 18 22:03:25 Server2 kernel: r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
  2. Mar 18 22:03:25 Server2 kernel: r8169 0000:03:00.0: can't disable ASPM; OS doesn't have ASPM control
  3. Mar 18 22:03:25 Server2 kernel: r8169 0000:03:00.0 eth0: RTL8168f/8111f at 0xffffc9000065a000, 60:a4:4c:38:f7:10, XID 08000800 IRQ 29
  4. Mar 18 22:03:25 Server2 kernel: r8169 0000:03:00.0 eth0: jumbo features [frames: 9200 bytes, tx checksumming: ko]
  5. Mar 18 22:03:26 Server2 kernel: r8169 0000:03:00.0 enp3s0: renamed from eth0
  6. Mar 18 22:03:31 Server2 kernel: r8169 0000:03:00.0 enp3s0: link down
  7. Mar 18 22:03:31 Server2 kernel: r8169 0000:03:00.0 enp3s0: link down
  8. Mar 18 22:03:33 Server2 kernel: r8169 0000:03:00.0 enp3s0: link up
複製代碼
it can get a static ip from router.

提示: 作者被禁止或刪除 內容自動屏蔽

TOP